Page 1 of 1

Apache 1.3.37 Problem

PostPosted: Sat Apr 10, 2010 11:04 am
by m3kk
Hello, recently i installed a 0.3.8 Freesco on a new HDD. I wanted to install the apache_1.3.37_dingetje, but i have two (2) issues with it..

When i install it stars, everything is OK, except the PHP, the PHP isnt working.. (tested with test.php).

When i do a reboot, then the apache disappears and the old httpd appears again..

With apache_1.3.27_dingetje all is OK.

Can you help me?
Thanks.

LE:

So i resolved the issue with the reboot, now Apache is starting after reboot too, before reboot i needed to copy the /rc/rc_httpd to /boot/pkg/rc .

Now the problem is: i have Apache installed, but the PHP didnt working..

With /usr/local/bin/php --version i got this:

Code: Select all
[root@Freesco] /usr/local/bin/php --version
PHP 4.4.4 (cli) (built: Oct 30 2006 01:06:41)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


But from any browser for testing php i got this :

Code: Select all
<?
phpinfo()
?>

Re: Apache 1.3.37 Problem

PostPosted: Sat Apr 10, 2010 11:46 am
by m3kk
Ok :).

I resolved this too.

The following must be added to the httpd.conf file:

Code: Select all
<IfModule mod_php4.c>
AddType application/x-httpd-php-source .phps
AddType application/x-httpd-php .php .wml
</IfModule>


But now the problem is the following:

Code: Select all
[root@Freesco] rc_httpd stop
Stopping http servers...                Done
[root@Freesco] rc_httpd stop
Stopping http servers...                Done
[root@Freesco] rc_httpd stop
Stopping http servers...                Done
[root@Freesco] rc_httpd restart
Stopping http servers...                Done
[root@Freesco] rc_httpd restart
Stopping http servers...                Done
[root@Freesco] rc_httpd start
[root@Freesco] rc_httpd start


So, i cant do a httpd stop, or restart without reboot :(.

Re: Apache 1.3.37 Problem

PostPosted: Sat Apr 10, 2010 9:15 pm
by Lightning
The problem is that you do not have the correct or updated version of the Apache package installed on your system. You need to install the beta version of the package which is version 1.3.27a and it has all of the various updates to be compatible with 0.3.7 and 0.3.8 or you should just update to the FREESCO 04x system if you have recently installed FREESCO and want the latest version of everything.
Under all situations I do NOT recommend installing the 1.3.37 version of the Apache package.

Re: Apache 1.3.37 Problem

PostPosted: Sun Apr 11, 2010 6:54 am
by m3kk
I dont like the 4.x due the changed setup menu, i`m familiar with 3.x :).

Thanks anyway.